<< Back
Message for this thread
Posted by Messages text
Ozols Val

Avatar
Total post : 58
> Profile
Written on : 10/11/2010 22:55 ( more than one month )
Object : [Solved] Scorm Errors
Using FF and Docebo's scormpackage.zip, I ran the "Locked" module with the following error:

"XML exception: TypeError: tom is null" (clicked OK)

"XML error: <br />
<b>Fatal error</b>:  Call to a member function getElementsByTagName() on a non-object in <b>/home/mysite/public_html/learning/doceboLms/modules/scorm/xmlwrapper.php</b> on line <b>303</b><br />" (clicked OK)

The module then ran as designed.  Same errors occurred with the "Free" module. Neither module showed it was complete.
Message modified by : Val on : 17/11/2010 20:36

 

 
Fabio Pirovano

Avatar
Total post : 538
> Profile
Written on : 12/11/2010 11:44 ( more than one month )
Object : Re: Scorm Errors
I've tried the same package and also the flashsample from our site and the old maritime package from ADL.

Tested on:
  • Firefox 3.6.12
  • Firefox 4 beta 6
  • Chrome 8
  • IE 8
But all works well.
CAn you please check in the configuration if the site url is correct ?


Fabio 
Docebo Staff

 - Docebo 4 released! -
 
Ozols Val

Avatar
Total post : 58
> Profile
Written on : 12/11/2010 19:20 ( more than one month )
Object : Re: Scorm Errors
Fabio,
Out of frustration, I downloaded the latest 4.0.1 and did a clean install with a new database. I am using FF 3.6.12 and the Docebo's scormpackage.zip. The configured URL is the one pulled from the install information. I still get the same errors. I then changed the URL and I still got the same result.  I even put in another website's URL and it didn't matter--the result was the same.

These are the configured URLs in main/configuration/settings/main options/website URL with final /:
http://www.mysite.com/learning/  (the default from the install)
http://www.mysite.com/learning/doceboLms/
http://www.mysite.com/
http://www.othersite.com/

 

 
FromDon John

Noavatar
Total post : 33
> Profile
Written on : 13/11/2010 12:27 ( more than one month )
Object : Re: Scorm Errors
Hi,

I have just gone through inserting a SCO into the system, it works great.  I have now gone to look at some of the other reports in User/objects grid.  I have the data from the completion of the SCO, and when I select Reset, I get the following error:

Fatal error: Call to undefined method Track_Object::deleteTrack() in /home/myhost/public_html/mysite/doceboLms/class.module/track.scorm.php on line 98

TIA
J
Regards
John
 
FromDon John

Noavatar
Total post : 33
> Profile
Written on : 13/11/2010 12:30 ( more than one month )
Object : Re: Scorm Errors
Hi

When you insert a SCO and play the file from the Teacher Menu, the course displays within the window fine, and displays the Close button. However, when I then resize the player to 810x600, the course then goes full screen.

TIA
J
Regards
John
 
Erba Claudio

Avatar
Total post : 2688
> Profile
Written on : 13/11/2010 17:08 ( more than one month )
Object : Re: Scorm Errors
Can you please open one bug per thread?
Claudio 
Docebo CEO and Founder
www.docebo.com
 
Ozols Val

Avatar
Total post : 58
> Profile
Written on : 17/11/2010 20:42 ( more than one month )
Object : Re: [Solved] Scorm Errors
Scorm error was being caused because the server configuration was set at Configuration of "register_global": ON

When I changed it to Configuration of "register_global": OFF, my errors disappeared.
Message modified by : Val on : 17/11/2010 20:44

 

 
Pereira Joaquim

Noavatar
Total post : 4
> Profile
Written on : 28/07/2011 17:36 ( more than one month )
Object : Re: [Solved] Scorm Errors
Val,

should the "register_global": OFF also solve the Server Failure: 500 error ??

I am fithing this error when we insert a SCORM package. Already test several SCROM converter tools and SCROM 1.2 and 2004 format.

This is error is happening on verison 4.0.4.

Anyone have an idia about this (our server is in Windows)

Thanks

Joaquim 
 
Pereira Joaquim

Noavatar
Total post : 4
> Profile
Written on : 30/07/2011 03:16 ( more than one month )
Object : Re: [Solved] Scorm Errors
Solved the problem.

In did, register_globals: OFF, will solve the problem of Server Failure 500.

Almost sware that i checked this configuration on the installation :) ...

thanks Val.. your post lead me to the solution

Joaquim 
 
<< Back